PatchClock

PHP security digest · 14 Sep 2026

October CMS: Incomplete Scheme Validation in Image Resizer

Low CVE-2026-100909

Package
october/october
Fixed in
4.3.5
Published
Mon 14 Sep 2026, 18:15 LisbonUpdated Mon 26 Oct 2026, 00:27 Lisbon
Installs on Packagist
273K

In plain words

The image resizer can accept non-HTTP(S) PHP stream sources and pass them to the image library, potentially triggering metadata deserialisation. This requires existing template-authoring or backend-configuration functionality that passes untrusted input into |resize or ResizeImages::resize(). Default templates and uses limited to trusted values are not exposed; an unauthenticated visitor cannot exploit the resize route alone.

Affected versions

PackageAffectedFixed in
october/october>= 4.3.0, < 4.3.44.3.5

Am I affected?

Check composer.lock for october/october at >= 4.3.0, < 4.3.4. If matched, inspect template code and backend widget configuration for |resize or direct ResizeImages::resize() calls that accept untrusted strings without scheme validation. Uses limited to uploaded file models, theme assets or trusted static URLs are not exposed. The advisory identifies 4.3.5 as the patched version.

What to do

Check which version you have, then update to a fixed release for your branch (4.3.5):

composer show october/october | grep versions
composer update october/october

If your version constraint in composer.json keeps you below a fixed release, raise it first. Whether your configuration is affected, and the exact version ranges, are in the advisory itself.

If you cannot update yet

Audit template code and backend widget configuration for |resize or direct ResizeImages::resize() calls that accept untrusted string input, and validate that the scheme is http or https before passing it in.

The advisory's description

The image resizer classified external sources by testing whether the source string began with the substring http, and the string-source branch in ResizeImageItem::fromObject() accepted any value containing :// as a URL. As a result, non-http(s) PHP stream wrappers such as phar://, file:// and ftp:// could be stored in the resizer cache and later passed to the underlying image library. On a phar:// path this can lead to metadata deserialization during subsequent file operations.

Exploitation requires an existing template-authoring or backend-configuration primitive that passes untrusted input into the |resize Twig filter (or the ResizeImages::resize() API). The /resize/{file} route itself is a lookup against a cache entry that was previously written by trusted server-side code, and an unauthenticated visitor cannot cause an arbitrary source path to be written into that cache. In October's trust model the Publisher and Developer backend roles that can author templates are already trusted with template code execution, so this is a defense-in-depth hardening rather than an unauthenticated network-to-RCE path.

Impact

  • On installations where a template author has piped untrusted input into |resize without validation, a phar:// source could reach the resizer and trigger metadata deserialization
  • No exposure on default templates or on installations where |resize is only applied to trusted values (uploaded file models, theme assets, static URLs)
  • Hardening; not exploitable from the network without a pre-existing injection primitive on the calling code

Patches

The vulnerability has been patched in v4.3.5.

Workarounds

If upgrading immediately is not possible:

  • Audit template code and backend widget configuration for uses of the |resize filter (or direct ResizeImages::resize() calls) that accept untrusted string input, and validate the scheme is http/https before passing it in

References

  • Reported by 0xGenesi

Weakness: CWE-20 Improper Input Validation. Reported by 0xGenesi.

The advisory

From OSV.dev, which gathers the GitHub Advisory Database, FriendsOfPHP and Drupal security advisories; the summary is theirs. The description, affected versions, weakness and credits are from the GitHub Advisory Database (CC BY 4.0). "In plain words", "Am I affected?" and "If you cannot update yet" are based on that advisory, and checked to name no version it does not.