PatchClock

PHP security digest · 27 Oct 2026

Symfony: ReDoS in HeaderUtils::split() Reachable Through the Cache-Control Request Header

High CVE-2026-108082

Packages
symfony/http-foundation, symfony/symfony
Fixed in
6.4.46, 7.4.19, 8.1.7, 5.4.54
Published
Tue 27 Oct 2026, 19:01 Lisbon
Installs on Packagist
1B

In plain words

An unauthenticated attacker can send a request with a crafted Cache-Control header that causes excessive CPU use, potentially denying service. This is reachable in any application handling HTTP requests because Symfony parses that header whenever a Request is built. If parsing reaches pcre.backtrack_limit, all directives in that header are silently dropped.

Affected versions

PackageAffectedFixed in
symfony/http-foundation>= 6.0.1, < 6.4.466.4.46
symfony/http-foundation>= 7.0.0, < 7.4.197.4.19
symfony/http-foundation>= 8.0.0, < 8.1.78.1.7
symfony/symfony>= 6.0.1, < 6.4.466.4.46
symfony/symfony>= 7.0.0, < 7.4.197.4.19
symfony/symfony>= 8.0.0, < 8.1.78.1.7
symfony/http-foundation>= 4.1.0, < 5.4.545.4.54
symfony/symfony>= 4.1.0, < 5.4.545.4.54

Am I affected?

In composer.lock, check the installed version of symfony/http-foundation or symfony/symfony. Affected ranges are >= 4.1.0, < 5.4.54, >= 6.0.1, < 6.4.46, >= 7.0.0, < 7.4.19 and >= 8.0.0, < 8.1.7. Check whether the application handles HTTP requests: parsing happens whenever a Request is built, with no authentication or special configuration required. When choosing an update, note that the initial fixes introduced a whitespace-separator regression; 6.4.48, 7.4.21 and 8.1.9 contain its correction.

What to do

Check which version you have, then update to a fixed release for your branch (6.4.46, 7.4.19, 8.1.7, 5.4.54):

composer show symfony/http-foundation | grep versions
composer update symfony/http-foundation

If your version constraint in composer.json keeps you below a fixed release, raise it first. Whether your configuration is affected, and the exact version ranges, are in the advisory itself.

The advisory's description

Description

HeaderUtils::split() parsed header values with a pattern whose token alternative also matched whitespace, followed by a (?<!\s) lookbehind. A run of whitespace placed before a separator could be divided among the iterations of the enclosing repetition in exponentially many ways, and the engine tried all of them before settling. HeaderBag calls it for the Cache-Control header whenever a Request is built, so any application handling HTTP requests is reachable, with no authentication.

A single request carrying such a header costs close to a second of CPU (813 ms for a run of 17 spaces in an 8 KB header on PHP 8.5, doubling with each extra space). From 18 spaces on, preg_match_all() gives up at pcre.backtrack_limit and split() returns an empty array, so every directive of the header is silently dropped.

Resolution

The pattern now consumes whitespace only when more of the value follows it, so a value can no longer end on whitespace, nothing has to be given back, and every quantifier is possessive. The first release of this fix broke splitting on a whitespace separator: HeaderUtils::split('foo bar', ' ') returned a single value in 6.4.46 to 6.4.47, 7.4.19 to 7.4.20 and 8.1.7 to 8.1.8. Whitespace characters used as separators are now left out of the whitespace branch, which 6.4.48, 7.4.21 and 8.1.9 contain.

The patches for this issue are available here for branch 5.4 (and forward-ported to 6.4, 7.4, 8.1 and 8.2).

Credits

Symfony would like to thank r3verii for reporting the issue and Nicolas Grekas for providing the fix.

Symfony would also like to thank Bruno Dias from Checkmarx for his help getting a CVE assigned.

Weakness: CWE-1333 Inefficient Regular Expression Complexity. Reported by r3verii, nicolas-grekas, duartecsantos.

The advisory

From OSV.dev, which gathers the GitHub Advisory Database, FriendsOfPHP and Drupal security advisories; the summary is theirs. The description, affected versions, weakness and credits are from the GitHub Advisory Database (CC BY 4.0). "In plain words", "Am I affected?" and "If you cannot update yet" are based on that advisory, and checked to name no version it does not.